Disclaimer: this is an auto-generated translation. Please feel free to contact us with improvement suggestions!

Your Atolia application is compatible with all recent browsers: Microsoft Edge, Google Chrome, Mozilla Firefox, Brave and Safari.
Make sure to update them as an older version (especially of Internet Explorer) will not allow the Atolia application to work properly.

Was this article helpful?
Cancel
Thank you!